Bounding Box

Bounding Box

Over het Blog:

Het Boundingbox-blog is opgezet om vondsten en bevinden op het gebied van maya te posten. Een persoonlijk weblog om mezelf te dwingen deze bevindingen neer te tikken, zodat ik ze later kan teruglezen.
En misschien dat iemand anders er wat aan heeft.

Maya 2013 Ubuntu 14.04

Maya on LinuxPosted by Arno de Grijs Tue, October 21, 2014 16:40:22
Nu dat ik elementary os freya gebruik (wat gebaseerd is op Ubuntu 14.04) en nog steeds maya 2013 gebruik, stuitte ik op het volgende probleem.
Maya 2013 maakt gebruik van python 2.6 terwijl de standaard python versie in ubuntu 14.04 python 2.7 is.
Normaal kon ik in maya modules importeren waar ik veel gebruik van maak door in mijn usersetup.py het pad van de locale versie van python toe te voegen (namelijk '/usr/local/lib/python2.6/dist-packages/').
Alleen dit gaf problemen vanwege op elementary os "freya"vanwege de verschillende versie van python. Maya gaf errors als ik het pad van '/usr/local/lib/python2.6/dist-packages/' naar '/usr/local/lib/python2.7/dist-packages/' veranderde. Als ik met deze aanpassing in mijn userSetup.py file modules in maya wilde importeren kreeg ik de ene na de andere error.

Omdat python 2.6 standaard niet geinstalleerd is op ubuntu 14.04, heb ik python 2.6 geinstalleerd. Daarna heb ik easy_install geinstalleerd door middel van gebruik te maken van python2.6. Ook heb ik pip2.6 geinstalleerd op dezelfde manier.
Nu kan ik voor python2.6 de meeste modules installeren via pip en easy_install, en geeft maya ook geen errors meer als ik modules probeer te importeren.
Sommige modules lukken niet omdat deze gecompiled worden specifiek voor python2.6 (zoals PyQt4), maar dat is de volgende stap.

  • Comments(0)